What's new
What's new

Mazak won’t home at all


Feb 27, 2023
We have a mazak 5 axis. Currently the rotary table is disconnected cause it has its own issues but the machine is not homing out. When the machine powers on, regardless of the position of the machine. It will recognize that position as 0 for x y and z axis. If I select home and move any of the axes in the negative direction they move at the feed speed and will keep going and crash unless stopped. In the plus direction the machine moves slowly regardless of the set feed speed.

This issue started because the machine has as alarm 9 absolute position malfunction (&00000001, &0017, ) and with that error the machine was still homing out and knew where it was. But I found something online that was supposed to get rid of the alarm. It asked me to home the machine, change parameter M18 but 7 to 0, power off and power on, then change parameter M18 back to what it was, then home machine again. This fixed the alarm until I power cycled the machine. Then the alarm was back and the machine refuses to home.

Any help would be appreciated, thank you
M18 bit 7 should be 1. When you make it ZERO you tell NC control to move axis until u hit DOG switch. You machine doesn't have DOG switch, it is absolute encoder machine.

I think you have to move axis where it needs to be as ZERO position and after you need to change M16 parameter. Just make it a bit smaller or bigger.

NC will recognize this change as request to re-establish Absolute Zero position and after, you need to press HOME for this particular axis to move a bit and reset its zero.

also, you can always swap encoders on X,Y,Z servo motors for troubleshooting.

P.S. Any hope to call local MAZAK technical service? They as a general rule might have spare encoder or servo Amplifier for testing.
Thank you for your suggestion. Currently all the axes have M16 at 0. I changed the z axis one to 10 and tried what you said and then switched to 100 and tried it. It didn’t seem to fix the issue. The z axis still just ignores zero point and goes past in both positive and negative direction. Just in case I also tried 1000 and -1000, and no luck. I don’t know what I’m doing wrong, any other suggestions? Thank you
I also have a Mazak that won't home at all. The difference is that my axis won't move no matter what I do, no matter what settings or buttons I've pressed. I'm sure my servos are on. I can request the spindle to rotate and that works fine, both directions and any speed I ask for.
My Mazak is 1995 VTC-41 with the Mazatrol EIA Yasnac control. This machine is new to me so I don't know the standard start up procedures.
I have learned about the DIAG screen showing the 0's and 1's and I'm betting that this machine is simply waiting for a door position switch or an air pressure switch to indicate a 1 before it will let it move. Since I have chased the air pressure and tried things like reversing the phasing and doors closed, and I have verified that each button changes a 0 to a 1, my new goal is to compare my first 3 DIAG screens with someone else's Mazak in order to learn what is different.
Either that or maybe someone else can offer a suggestion that I haven't thought of yet. Please HELP!
NOTES: The machine says LSK and RDY in the lower right hand corner. I don't know what LSK stands for but it does change to F when I set MDI and ask it to feed and it will change to an R when in MDI and I ask it to G91G0 any axis any direction. but it will just sit there, showing the F or R, yet not feeding or rappiding.Alarm517.jpgDIAG1.jpgDIAG2.jpgDIAG3.jpg
What control your 5x MAZAK? What type of MDS units it has? Very strange that M16 parameters are set to zero, as they here to adjust grid shift.
They are Mitsubishi drives the x,y axis drive is MDS-DH2-V2-4040 and the z axis is MDS-DH-V1-40. According to my manual that shows M16 is still the parameter for grid shift but it’s just 0.


  • IMG_4211.jpeg
    4.2 MB · Views: 4
They are Mitsubishi drives the x,y axis drive is MDS-DH2-V2-4040 and the z axis is MDS-DH-V1-40. According to my manual that shows M16 is still the parameter for grid shift but it’s just 0.
do you have any parameters backup on the machine hard drive? There must be a file, machine parameters backup, that was made after was installed and commissioned. M16 should have some numbers. Also you can probably find SRAM backup on your hard drive and try to reload it. MAke sure you create a new one, up to date before loading original parameters and SRAM. Just in case.

Can you contact local MAZAK people and ask them to email your machine parameters ( they should have a backup somewhere) or similar to your machine configuration.
Last edited: